A A A

Please consider registering
guest

Log In

Lost password?
Advanced Search:

— Forum Scope —



— Match —



— Forum Options —




Wildcard usage:
*  matches any number of characters    %  matches exactly one character

Minimum search word length is 4 characters - maximum search word length is 84 characters

Topic RSS
/usr/lib/dld.sl: Unresolved symbol: imaxdiv (code) from /bin/bash
October 13, 2014
2:27 pm
Lo0oM
Admin
Forum Posts: 217
Member Since:
September 30, 2012
Offline

Hi

 

Description:

 

Compilation process with gcc compiler on HPUX 11.11 ends with following errors:

/usr/lib/dld.sl: Unresolved symbol: imaxdiv (code)  from /bin/bash

/bin/sh: 15857 Abort(coredump)

 

figure out the reason:

bash-4.3# ldd -r /bin/bash
        /usr/lib/libc.2 =>      /usr/lib/libc.2
        /usr/lib/libdld.2 =>    /usr/lib/libdld.2
        /usr/lib/libc.2 =>      /usr/lib/libc.2
        /usr/local/lib/libiconv.sl =>   /usr/local/lib/libiconv.sl
        /usr/lib/libc.2 =>      /usr/lib/libc.2
        /usr/local/lib/libintl.sl =>    /usr/local/lib/libintl.sl
        /usr/local/lib/libiconv.sl =>   /usr/local/lib/libiconv.sl
        /usr/local/lib/libtermcap.sl => /usr/local/lib/libtermcap.sl
        symbol not found: __pwrite64    (/bin/bash)
        symbol not found: _isblank      (/bin/bash)
        symbol not found: imaxdiv       (/bin/bash)
        symbol not found: __pread64     (/bin/bash)

versions of packages installed:

  bash                         4.3.030    
  gcc                           4.2.3       
  gettext                      0.18.3.2   
  libiconv                      1.14         
  termcap                    1.3.1        

 

Solution:

 

1. It is simple, remove bash at all or install older version of package, because latest seems to have issues. I downgraded bash

to version 4.2.0-45. There 2 ways to remove packages through swremove or depothelper.

# depothelper -u bash (or swremove bash)

# swinstall -s /opt/inst/bash-4.2-hppa-11.11.depot

 

Now check.

bash-4.3# ldd -r /bin/bash
        /usr/lib/libc.2 =>      /usr/lib/libc.2
        /usr/lib/libdld.2 =>    /usr/lib/libdld.2
        /usr/lib/libc.2 =>      /usr/lib/libc.2
        /usr/local/lib/libiconv.sl =>   /usr/local/lib/libiconv.sl
        /usr/lib/libc.2 =>      /usr/lib/libc.2
        /usr/local/lib/libintl.sl =>    /usr/local/lib/libintl.sl
        /usr/local/lib/libiconv.sl =>   /usr/local/lib/libiconv.sl
        /usr/local/lib/libtermcap.sl => /usr/local/lib/libtermcap.sl

 

 

All is fine and compilation will work.

 

Thank you.

 

 

 

 

Forum Timezone: UTC 0

Most Users Ever Online: 31

Currently Online:
4 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Member Stats:

Guest Posters: 0

Members: 0

Moderators: 0

Admins: 1

Forum Stats:

Groups: 3

Forums: 20

Topics: 214

Posts: 214

Newest Members: Lo0oM

Administrators: Lo0oM (217)