A A A

Please consider registering
guest

Log In

Lost password?
Advanced Search:

— Forum Scope —



— Match —



— Forum Options —




Wildcard usage:
*  matches any number of characters    %  matches exactly one character

Minimum search word length is 4 characters - maximum search word length is 84 characters

Topic RSS
cannot mount '/zones': directory is not empty
April 28, 2015
12:27 pm
Lo0oM
Admin
Forum Posts: 217
Member Since:
September 30, 2012
Offline

Hi

 

Description:

I have Solaris 11 server which fail to boot with error:

cannot mount '/zones': directory is not empty

# svcs -l svc:/system/filesystem/local
fmri         svc:/system/filesystem/local:default
name         local file system mounts
enabled      true
state        maintenance
next_state   none
state_time   Thu Jun 03 18:00:01 2010
logfile      /var/svc/log/system-filesystem-local:default.log
restarter    svc:/system/svc/restarter:default
dependency   require_all/none svc:/milestone/single-user (online)
dependency   require_all/none svc:/system/filesystem/minimal (online)
dependency   require_all/none svc:/system/vxvm/vxvm-reconfig (online)

 

I have zone installed in /zones directory and for unknown reason server failed to start after it worked for months before.

 

Solution:

1. I found that if i mount this folder with -O option server will work.

# zfs mount -O rpool/zones 

# svcs -xv

#

 

But after server reboot i see the same error

 

2. So i changed zoned parameter for this folder:

# zfs set zoned=on rpool/zones

 

Now all works.

 

Thank you.

 

Forum Timezone: UTC 0

Most Users Ever Online: 31

Currently Online:
1 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Member Stats:

Guest Posters: 0

Members: 0

Moderators: 0

Admins: 1

Forum Stats:

Groups: 3

Forums: 20

Topics: 214

Posts: 214

Newest Members: Lo0oM

Administrators: Lo0oM (217)